Watson Workspace will no longer be available after February 28, 2019. Learn more.

Developers

Comments

6 comments

  • Avatar
    Kirti Gani

    The callback url for the webhook has to be open, ie not requiring authentication, when I try to hit both of those I get a prompt for credentials. 

  • Avatar
    Miguel Estrada

    Hi Krishnakumar,

    Just to make sure I am understanding correctly...  

    1. Are you trying to get this example to work?https://github.com/watsonwork/watsonwork-weather

    2. Is your app hosted in bluemix?

    3. What is this URL referring to? https://twcservice.mybluemix.net/weather

    4. Are you able to make some of the other samples work such as:

    https://github.com/watsonwork/watsonwork-echo

    or

    https://github.com/watsonwork/watsonwork-sentiment

  • Avatar
    KRISHNAKUMAR BALACHANDAR

    Thanks for the comments. yes I am trying out watson-weather sample. The app is hosted on bluemix. 

    My callback URL is incorrect and I will try out after deploying my app to bluemix. 

  • Avatar
    KRISHNAKUMAR BALACHANDAR

    I have tried multiple options but still getting errors. 

    watson-weather   

    bluemix build and deploy =>  Snippet from bluemix log file 

    2017-08-28T13:43:19.57+0530 [APP/PROC/WEB/0] OUT > node lib/app.js
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR module.js:471[0m
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR throw err;[0m
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR ^[0m
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR Error: Cannot find module '/home/vcap/app/lib/app.js'[0m
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR at Function.Module._resolveFilename (module.js:469:15)[0m
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR at Function.Module._load (module.js:417:25)[0m
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR at Module.runMain (module.js:604:10)[0m
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR at run (bootstrap_node.js:389:7)[0m
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR at startup (bootstrap_node.js:149:9)[0m
    [31m2017-08-28T13:43:19.76+0530 [APP/PROC/WEB/0] ERR at bootstrap_node.js:504:3[0m
    [31m2017-08-28T13:43:19.78+0530 [APP/PROC/WEB/0] ERR npm ERR! code ELIFECYCLE[0m
    [31m2017-08-28T13:43:19.78+0530 [APP/PROC/WEB/0] ERR npm ERR! errno 1[0m
    [31m2017-08-28T13:43:19.78+0530 [APP/PROC/WEB/0] ERR npm ERR! watsonwork-weather@0.0.1 start: `node lib/app.js`[0m
    [31m2017-08-28T13:43:19.78+0530 [APP/PROC/WEB/0] ERR npm ERR! Exit status 1[0m
    [31m2017-08-28T13:43:19.78+0530 [APP/PROC/WEB/0] ERR npm ERR! [0m
    [31m2017-08-28T13:43:19.78+0530 [APP/PROC/WEB/0] ERR npm ERR! Failed at the watsonwork-weather@0.0.1 start script.[0m

     

     

  • Avatar
    KRISHNAKUMAR BALACHANDAR

    I have got the weather app running on my local machine.  I am unable to get the webhook Enable to  work. Are there any debug techniques to check if the webhook challenge POST request hits my App. I tried Chrome Postman but the Header requires X-OUTBOUND-TOKEN. 

  • Avatar
    Miguel Estrada

    Here are a couple of suggestions:

    You should be able to debug if http requests reach your app independent of the details of Watson Work Weather example.  That is more related to networking and your machine / setup including ip address, ssl certificates, etc.  See the "running app locally" section here: https://github.com/watsonwork/watsonwork-weather

    You can also use a free bluemix account to run your nodejs app and a simpler app such as echo or the sentiment one to help isolate problems.

Please sign in to leave a comment.